
Innovative Systems Design and Engineering                                                                                                                                     www.iiste.org 
ISSN 2222-1727 (Paper) ISSN 2222-2871 (Online)  DOI: 10.7176/ISDE 
Vol.10, No.4, 2019 
 

26 

Result Computation for Tertiary Institution using Microsoft Excel (A Case Study of Bayelsa State College of Arts and Science, Elebele, Bayelsa State)  
EMMANUEL D. ASSOR 

Department of Computer Science, Bayelsa State College of Arts and Science, Elebele  Abstract  
A student’s result is the criteria for the measurement of the student’s capability in terms of academic work in the 
school. It is also used to measure a student’s capability in each subject offered by the student. Without an 
adequate result processing system, the aim for which results are produced may not be achieved, because any 
slight or minor of mistake made during the process might lead to a very big problem. This research is tailored 
towards the understanding and implementation of a computer based GPA and CGPA computation using 
spreadsheet application program like Microsoft Excel to handle all related calculations thereby enhancing the 
preparation and presentation of student grading system for effective student result preparation and to serve as 
quick guide to lecturers and examination officers. However, all concerned personnel that have the task of result 
computation, are encouraged to study with keen interest in that they can hand GPA/CGPA computations so as to 
avert wrong implementation of student scores calculations/computations in the future. Keywords: Result, Examination Scores, GPA, CGPA, Password, Computerized, Data Entry DOI: 10.7176/ISDE/10-4-04 Publication date:May 31st 2019  INTRODUCTION 
In the light of the modern trend of using the Computer System to make manual task easier, the use of computer 
to compute student results (GPA/CGPA) has become imperative. This is because this project will not only 
reduce the tedious nature of manual computation of results, but will also improve in greater accuracy, efficiency 
and standardized result computation. 

Excel makes the calculations of student result much easier than working things out yourself with a 
calculator, Depending on your understanding and skill with Excel, The formulas and equations are used to 
quickly compute both simple and complex equations using large amounts of data. This project will greatly aid all 
stakeholders to compute student results in an easier and better way. It is also important that all computed 
GPA/CGPA computation be recorded on removable disks – Compact Disk (CD) for future reference based on 
one academic year to another with accurate labels on them. This can be used to prepare student transcript in the 
future on request since such records will be in Portable Document Format (PDF) for safe keep and for easy 
retrieval as well as password to present unauthorized persons. Also with this project a specific format (template) 
be design for all our result, because this will give a specific format for all departments and schools result in the 
college.  Benefits of Microsoft Excel for Student Result Computation 
� Excel has the ability to organize large amounts of data into orderly spreadsheets and charts quickly, it 

is easy to enter and format the data, it has the ability to create the graphical or the visual representations of 
your data, and it is easy to integrate Excel with other business applications. 

� Excel can be used for analysis and decision making, it allows you to put the grades on a spreadsheet by 
numbers which then allows the students to access the spreadsheet and view their grades on the exams and 
the quizzes. 

� It is a part of Microsoft office which comes with most PC so there is no need to purchase or install it, it is an 
all in one programs and does not need the addition of financial subsets, and there is training programs 
and training courses to make the users more familiar with Excel. 

� Excel files can be password protected for extra security , The user can create a password through Visual 
Basic programming or directly within the Excel file , It is capable of connecting directly to OLAP databases 
and it can be integrated in Pivot Tables . 

� You can make easy and effective comparisons with the powerful analytical tools included within Microsoft 
Excel you have the ability to analyze large amounts of data to discover trends and patterns that will 
influence decisions. 

� In Microsoft Excel, The worksheets can contain thousands of rows of data in the form of records and 
multiple columns in the form of fields, you can get a quick overview by sorting and summarizing the data. 

� Excel makes it easy to store the data, perform numerical calculations, format the cells, and adjust layouts to 
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generate the output and reports to share with others.  OLD SYSTEM OF RESULT COMPUTATION IN BYCAS 
It has been my dream to see how student’s results in tertiary institutions in Nigeria use automated computerized 
system by applying spreadsheet package like Microsoft Excel application software which is a spreadsheet 
software in calculating students GPA and CGPA result. In the Bayelsa State College of Arts and Science Elebele, 
Yenagoa, and other similar tertiary institutions in Nigeria, it has being so tedious using manual calculator in 
calculating students first and second semester results, with a lot of errors in calculating, and result difficulties in 
rounding up numbers. The manual method adopted in results processing pose some problem, these problems 
includes the following:  
• Poor Security of Documents 
• Untimely Processing Results:  
• Production of Inaccurate Results 
The distinguishing feature of a spreadsheet program such as Excel is that it allows you to create mathematical 
formulas and execute functions. This project is carried out to prepare this easy steps of calculating student GPA 
and CGPA for all semesters using Microsoft Excel.   MICROSOFT EXCEL PACKAGE  
The importance of Microsoft Excel cannot be overemphasized, Microsoft Excel 2010 is a full-featured 
spreadsheet program that helps you quickly and efficiently develop dynamic, professional workbooks to 
summarize and present your data.  

Microsoft Excel is one of the most popular electronic spreadsheet applications that helps you manage a raw 
data into information, create visually persuasive charts, and thought-provoking graphs. It is a data processing 
application that can allow you add formulas and functions to perform calculations; and analyze, share, and 
manage information by using charts and tables. Excel also has options for adding pictures, shapes, and 
screenshots to a spreadsheet.  A spreadsheet is a paper or electronic document that is used to store and manipulate data. It consists of rows and 
columns that intersect to form cells, where the data you enter is stored. A workbook is an Excel file that acts as a binder for related Excel worksheets. The title bar of the Excel 
application window displays the name of the workbook.  A worksheet is an electronic spreadsheet that is used for entering and storing data in Excel. An Excel worksheet 
contains columns and rows, which intersect like a grid to form cells.  A cell in an Excel file that acts as a binder for related Excel worksheets. The title bar of the Excel application 
window displays the name of the workbook.  
 OVERVIEW OF THE USER INTERFACE OF EXCEL 2010 
All the Microsoft Office 2010 programs share a common user interface so you can apply basic techniques that 
you learn in one program to other programs. The Excel 2010 program window is easy to navigate and simple to 
use. 
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Working with the ribbon 
As with all Office 2010 programs, the Excel ribbon is dynamic, meaning that as its width changes, its buttons 
adapt to the available space. As a result, a button might be large or small, it might or might not have a label, or it 
might even be an entry in a list. For example, when sufficient horizontal space is available, the buttons on the 
Home tab are spread out, and the available commands in each group are visible. If you decrease the horizontal 
space available to the ribbon, small button labels disappear and entire groups of buttons might hide under one 
button that represents the entire group.  

The ribbon is a graphical menu panel that appears at the top of the application window. It was designed to 
provide a central location for accessing various functions of the environment without having to navigate the user 
interface extensively. The ribbon is made up of two parts: the tabs and the command groups that make up each 
tab. Each tab has an organizational title that references the specific functions that the command groups within 
that tab provide. Each command group also has an organizational title, with the specific commands within each 
group associated with a specific task in the application environment. Clicking the group button displays a list the 
commands available in that group. You can minimize or expand the ribbon to display all the groups. We have the 
following ribbons – Home, Insert, Page Layout, Formulas, Data, Review, View Add-Ins and Acrobat.                                                     Functions of the toolbars:  
The Microsoft work sheet is made of difference toolbars for different functions:  
They as follows:  
 Quick Access Toolbar 
The Quick Access Toolbar lets you access common commands no matter 
which tab is selected. It includes the Save, Undo, and Repeat commands. 
You can add other commands depending on your preference.  Dialog Box Launchers 
Some command groups on the ribbon will have a small downward-arrow button located at the bottom-right 
corner of the command group box. The button is called a Dialog Box Launcher, and when selected, opens a 
dialog box with additional features or functions available for that command group.  Formula Bar/Name Box: In the formula bar, you can enter or edit data, a formula, or a function that will appear in a specific cell. In the image below, 
cell C1 is selected and 2014 is entered into the formula bar. Note how the data 
appears in both the formula bar and in cell Name Box C1.  Entering Data into a cell 
1. Click the desired cell (the cell name appear in the name box).  
2. Type the data into the cell (it will appear in the formula bar). 
3. Press the Enter key to move down a cell.  
4. Press the Tab key to move to the next cell to the right.   Naming a Worksheet  
1. Double-click the Sheet1 worksheet tab, then click Rename.  
2. Type the desired name and press Enter on the keyboard.  
 Saving the Workbook in the 2010 Format  
1. Click FILE > Save.  
2. Click Browse.  
3. Click the Save as type: drop-down menu and click     
    Excel Workbook (*.xlsx).  
4. Enter a name for the file in the File name: field.  
5. Click Save.   Changing an Entry within a Cell 
You may change an entry within a cell three (3) different ways: 
1. Click the cell one time and begin typing. The new information will replace any information that was 
previously entered in that cell. 
2. Double click the cell and a cursor will appear inside. This allows you to edit certain pieces of information 
within the cells instead of replacing all of the data. 



Innovative Systems Design and Engineering                                                                                                                                     www.iiste.org 
ISSN 2222-1727 (Paper) ISSN 2222-2871 (Online)  DOI: 10.7176/ISDE 
Vol.10, No.4, 2019 
 

29 

3. Click the cell, once and from the formula bar edit your information.  How to CUT, COPY, AND PASTE with the Microsoft Excel  
You can use the Cut, Copy and Paste features of Excel to change the data within your spreadsheet, to move 
data from other spreadsheets into new spreadsheets, and to save yourself the time of re-entering information in a 
spreadsheet.  Cut will actually remove the selection from the original location and allow it to be placed somewhere else.  Copy allows you to leave the original selection where it is and insert a copy elsewhere.  
 Paste is used to insert data that has been cut or copied. 
1. Highlight the data or text by selecting the cells that they are held within. 
2. Go to the Home Tab > Copy (CTRL + C) or Home Tab > Cut (CTRL + X). 
3. Click the location where the information should be placed. 
4. Go to Home Tab > Paste (CTRL + V) to be able to paste your information.  Number: Allows you to change the measurement in which 
your data is used. (If your data is concerned with money the 
number that you would use is currency) 
 Alignment: This allows you to change the horizontal and 
vertical alignment of your text within each cell. You can also 
change the orientation of the text within the cells and the 
control of the text within the cells as well.  Font: Gives the option to change the size, style, color, and effects. Border: Gives the option to change the design of the border 
around or through the cells.  How to Undo and Redo 
In order to undo an action, you can click on the blue arrow icon that is pointing to 
the left at the top of the screen. To redo an action, you can click on the blue arrow 
icon pointing to the right. It is important to note that not all actions are undoable, 
thus it is important to save before you make any major changes in your document so 
you can revert back to your saved document.   Data entry cell by cell To enter either numbers or text: 
1. Click on the cell where you want the data to be stored, so that the cell becomes active. 
2. Type the number or text. 
3. Press [ENTER] to move to the next row, or [TAB] to move to the next column. Until you’ve pressed [ENTER] 
or [TAB], you can cancel the data entry by pressing [ESC]. To enter a date, use a slash or hyphen between the 
day, month and year, for example 14/02/2009. Use a colon between hours, minutes and seconds, for example 
13:45:20. 
 Deleting data 
You want to delete data that’s already been entered in a worksheet? Simple! 
1. Select the cell or cells containing data to be deleted. 
2. Press the [DEL] key on your keyboard. 
3. The cells remain in the same position as before, but their contents are deleted.  Moving data 
You’ve already entered some data, and want to move it to a different area on the worksheet? 
1. Select the cells you want to move (they will become highlighted). 
2. Move the cursor to the border of the highlighted cells. When the cursor changes from a white cross to a four-
headed arrow (the move pointer), hold down the left mouse button. 
3. Drag the selected cells to a new area of the worksheet, then release the mouse button. 
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Copying Data 
To copy existing cell contents to another area on the worksheet: 
1. Select the cells you want to copy (they will become highlighted). 
2. Move the cursor to the border of the highlighted cells while holding down the [CTRL] key. When the cursor 
changes from a white cross to a hollow left-pointing arrow (the copy pointer), hold down the 
left mouse button. 
3. Drag the selected cells to a second area of the worksheet, then release the mouse button. 
 
To copy the contents of one cell to a set of adjacent cells, select the initial cell and then move 
the cursor over the small square in the bottom right-hand corner (the Fill Handle).  
 How to use Auto Fill COMMAND 
This is one of Excel’s niftiest features! It takes no effort at all to repeat a data series (such as the 
days of the week, months of the year, or a numbers series such as odd numbers) over a range of cells. 
1. Enter the start of the series into a few adjacent cells (enough to show the underlying pattern). 
2. Select the cells that contain series data. 
3. Move the cursor over the small square in the bottom right-hand corner of the selection (the fill handle). Hold 
down the left mouse button and drag to a range of adjacent cells. 
4. The target cells will be filled based on the pattern of the original series cells.  Note: The cursor will change from a white cross to a black cross. Hold down the LEFT mouse button and drag 
to a range of adjacent cells. The initial cell contents will be copied to the other cells. 
 Selecting cells 
Using the mouse: 
• Click on a cell to select it. 
• You can select a range of adjacent cells by clicking on the first one, and then dragging the mouse over the 

others. 
• You can select a set of non-adjacent cells by clicking on the first one, and then holding down the [CTRL] 

key as you click on the others. 
 Using the keyboard: 
• Use the arrow keys to move to the desired cell, which is automatically selected. 
• To select multiple cells, hold down the [SHIFT] key while the first cell is active, and then use the arrow 

keys to select the rest of the range.  Selecting rows or columns 
To select all the cells in a particular row, just click on the row number (1, 2, 3, etc) at the left edge of the 
worksheet. Hold down the mouse button and drag across row numbers to select multiple adjacent rows. Hold 
down [CTRL] if you want to select a set of non-adjacent rows. Similarly, to select all the cells in column, you 
should click on the column heading (A, B, C, etc.) at the top edge of the worksheet. Hold down the mouse button 
and drag across column headings to select multiple adjacent columns. Hold down [CTRL] if you want to select a 
set of non-adjacent columns. 
You can quickly select all the cells in a worksheet by clicking the square to the immediate left of the Column A heading (just above the label for Row 1).  How to Insert, Manipulate, and Delete Cells, Columns, and Rows  
Here are the general steps you will use to insert, manipulate, and delete cells, columns, 
and rows. 
Insert or Delete Columns or Rows 
 To Insert or Delete a Column or a Row: 1. Select a column or row. 2. Select HOME → Cells → Insert to insert a column or row. 
 3. Select HOME → Cells → Delete to delete a column or row. 
 To Insert or Delete a Cell Range 1. Select a cell range. 
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2. Select HOME, and in the Cells group, from the Insert or Delete drop-down list, select Insert Cells or Delete Cells. 3. In the Insert or Delete dialog box, select the preferred option to shift cells up, down, left, or right, and then 
select OK.   Change Column Width 1. If necessary, change the column width to a specific value. a. Select the column that you want to change. b. Either display the pop-up menu, by right-clicking the selected column, and 
then select Column Width, or select HOME → Cells → Format, and then, 
in the Cell Size section, select Column Width.  c. In the Column Width dialog box, in the Column width text box, type a 
new value for the column width. d. Select OK.  2. If necessary, in the column header, drag the column's right border to the left or right to adjust the column 
width manually.  3. If necessary, in the column header, double-click the right border to automatically fit the overflowing text. 
 Change Row Height To change row height: 1. If necessary, change the row height to a specific value. a. Select the row that you want to change. b. Either display the pop-up menu, by right-clicking the selected row, and then select Row Height, or select HOME →Cells →Format, and then, in the Cell Size section, select Row Height. c. In the Row Height dialog box, in the Row height text box, type a new value for the 
row height. d. Select OK.  2. If necessary, in the row header, drag the lower border up or down to adjust the row height manually.   3. If necessary, in the row header, double-click the lower border to automatically fit the overflowing text. 
 Renaming Worksheet 
Each worksheet has a name that appears on its tab at the bottom of the workbook window by default, the 
worksheet are named Sheet, followed by number (Sheet1, Sheet2, etc). You can replace the default worksheet 
names to enable naming the sheet as first or second semester in this project.  Rename a Worksheet 

1. Double-click the tab of the worksheet that you want to rename 
or right click the worksheet tab and then click Rename on the 
shortcut menu. The worksheet name is selected on the tab. 

2. Type a new name and then press the enter key. 
Note: worksheet name can have up to 31 character and can include 
letters, numbers, symbols and space. Freezing Panes 
Freezing panes is a useful technique for keeping an area of a worksheet 
visible while you scroll to another area of the worksheet. In this project the need for using the freeze pane tool is 
key, because it will enable you work with large amount of student records.   To Freeze Pane 

1. Select the cell below the row and to the right of the column that you want to freeze. 
2. On the View tab in the Window group, click freeze Pane button, and then click freeze Pane.    
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Wrap Text in a Cell To wrap text in a cell: 1. Select the cell or cell range that you want to affect. 2. Select HOME →Alignment →Wrap Text. Note: You 
can also use the Text Control section of the Alignment tab 
in the Format Cells dialog box to wrap cell contents. This 
section also enables you to shrink the text to be visible 
within the cell. 
 Merge or Unmerge Cells To merge or unmerge cells: 1. Select the range of contiguous cells that you want to 
merge, or a merged cell that you want to unmerge. 2. Select HOME →Alignment, display the Merge & Center drop-down list, and select an option. Note: You can also use the Mini toolbar or the Text Control 
section of the Alignment tab in the Format Cells dialog box to merge or unmerge cells.  The Merge & Center Options 
In Excel, you can merge contiguous cells across columns or rows, and when cells have been merged, you can 
revert them to individual cells. The Merge & Center options are located on the HOME tab, in the Alignment 
group.  Alignment Options 
In Excel, Alignment options enable you to control the vertical and horizontal placement of content within a cell. 
You can access them on the HOME tab, in the Alignment group.  To Add Borders to Cells: Here are the general steps you will use to 
add borders and color to cells. 1. Select the cells to which you want to add borders. 2. On the HOME tab, in the Font group, display the Border drop-
down list, and select a border.  
 To use the Mini Toolbar or the Format Cells Dialog Box to apply Borders to Cells: 1. Select the cells to which you want to add borders. 2. Add the borders. 
� Right-click the cells to display the Mini toolbar, then display the Border drop-down list and select a border. 
� Select HOME →Cells →Format →Format Cells. On the Border tab, select a Line, Color, Presets, and Border option, 

preview the border, and select OK. 
 To Modify a Cell Borders Backgrounds 1. Select a cell that contains the border that you want to modify. 2. To change the line color or style, display the Border drop-down list, select Line Color or Line Style, and 
select a color or style from the displayed gallery. The pointer changes to a pencil. 3. Select the lines to which you want to apply the color or style. 4. Select the Border button, or press Esc to revert to the default pointer. Note: You can also modify borders 
using the Mini toolbar or the Format Cells dialog box.  To Remove a Cell Border: 1. Select the cell or cells from which you want to remove the borders. 2. On the HOME tab, in the Font group, display the Border drop-down list, and select No Border.  To use the Mini toolbar or the Format Cells dialog box to remove borders from cells: 1. Select the desired cell or cells. 2. Remove the borders. 
• From the Mini toolbar, display the Border drop-down list, and select No Border. 
• Select HOME →Cells →Format →Format Cells. On the Border tab, in the Presets section, select none, and 
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then select OK.  To Change Font Properties by Using the Ribbon: 1. Select the cell or cells that contain the data you want to format. 2. To change the font face, on the HOME tab of the ribbon, in the Font group, select a font from the Fonts drop-
down list. 3. To change the font size, on the HOME tab of the ribbon, in the Font group, select a font size from the Font Size drop-down list, or select either the Increase Font Size or Decrease Font Size button. 4. To change the font color, on the HOME tab of the ribbon, in the Font group, select a color from the Font Color drop-down list. 5. To change the font style, select the Bold, Italic, or Underline button. Note: You can also use the Mini toolbar 
to change font face, size, color, and type style.  Creating Headers  
1. Click the Page Layout View icon on the right side of the status bar.  
2. Click the location for the header to be placed.  
3. Type in the header name.  
4. Click anywhere in the worksheet, when finished  
5. Click the Normal View icon on the right side of the status bar to 
return to normal view.   Changing Orientation  
1. Click the PAGE LAYOUT tab.  
2. In the Page Setup group, click Orientation.  
3. Click the desired orientation (Portrait /Landscape).   Access the Page Setup dialog box  
1. Click the PAGE LAYOUT tab  
2. In the Page Setup group, click Print Titles.  
a. This shows the Page Setup dialog box containing many tools for 
modifying how the spreadsheet will look once printed.   PRINTING WORKSHEET 
It is important to always save your document before you print! 
 
To print your document, go to File Tab > Print, select your 
desired settings, and then click OK. You can also do this by using 
the shortcut CTRL + P 
 
To be able to change the orientation of your page for printing you 
can click on the Portrait Orientation button under the option, 
under Print then click the change the layout.   BASIC MATHEMATICAL OPERATIONS Entering Formulas 
After the equal sign, a formula includes the addresses of the cells whose values will be manipulated with 
appropriate operands placed in between. Arithmetic, comparison, text concatenation, and reference. But in this 
project will be looking at two of these operators. i.e (Arithmetic operators and comparison operators)  Arithmetic Operators 
To perform basic mathematical operations such as addition, subtraction, or multiplication; combine numbers; 
and produce numeric results, use the following arithmetic operators.    
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Types of operators: Arithmetic operator Meaning Example 
+ (plus sign) Addition 5+4 (=SUM (A7+A9) 

– (minus sign) Subtraction 3–1 =(A7-A9) 

* (asterisk) Multiplication 3*3 =(A7*A9) 

/ (Division) Division 2/6 =(A2/A6) 

ˆ (Exponents) Exponents 22   =2ˆ2  Comparison operators used in this project 
You can compare two values with the following operators. When two values are compared by using these 
operators, the result is a logical value either TRUE or FALSE. 

In either case, all formulas and functions are entered in a cell and must begin with an the equal sign “=” Comparison operator Meaning  Example 
= (equal sign) Equal to  A1=B1 

> (greater than sign) Greater than  A1>B1 

< (less than sign) Less than  A1<B1 

>= (greater than or equal to sign) Greater than or equal to  A1>=B1  Grading System in Bayelsa State College of Arts and Science  
Grading system in Bayelsa State College of Arts and Science, Elebele (BYCAS) is done using four (4) point 
grading system and a student’s performance in any semester is recorded as the Grade Point Average (GPA) 
which is a fraction of the course unit and the Weighted Grade Point (WGP). Since the inception of the institution 
it is observed that examination officers and lecturers are using calculators in processing student’s results which 
takes longer period of time and lots of errors in calculating students’ results. 

The table below shows the letter grades used by most Nigerian Polytechnics and their corresponding 
percentage scores and weighted grades. SCORES (%) LETTER GRADE WGP 

75  -100 A1 4.00 
70  -74 A2 3.50 
65  -69 B1 3.25 
60  -64 B2 3.00 
55  -59 C1 2.75 
50  -54 C2 2.50 
45  -49 D1 2.25 
40  -44 D2 2.00 
00  -30 F 0.00 

 COMPUTATION USING CELL REFERENCE IN MS EXCEL 
Using cell references in formulas and functions is also important when you copy a formula or function. When 
you copy the formula or function, the cell addresses will be copied in a particular way depending on how the 
cells are referenced. Specifically, Excel records cell addresses in formulas and functions in three different ways: 

• Relative cell reference. 
• Absolute cell reference. 
• Mixed cell reference 

Copying formulas and functions instead of typing them into a new cell obviously avoids typing errors and will 
save you time. 
 Relative Cell References 
Calling cells by just their column and row labels (such as ‘A1’) is called a relative cell reference. When formulas 
or functions contain relative cell referencing and they are copied from one cell to another, Excel does not create 
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$A$A
Locks Column  Locks Row  

A$1 
Column Changes Row is Locks  

an exact copy of the formula or function. Instead, Excel changes the cell addresses relative to the row and 
column they are moved to. 
 EXAMPLE: 
If a simple addition formula of ’ =A1+B1’ in cellC1is copied to cell C2, the formula would change to ’=A2+B2’ 
to reflect the new row. Absolute Cell References 
An absolute cell reference refers to the same cell, no matter where the formula or function is copied. In other 
words, when a formula or function containing an absolute cell reference is copied to a new location, the cell 
reference is not adjusted. 

An absolute reference in Excel is a cell reference with the dollar ($) sign, like $A$1. The dollar sign fixes 
the reference to a given cell, so that it remains static no matter where the formula moves. In other words, using 
dollar ($) in cell references allows you to copy the formula in Excel without changing references.  

The dollar ($) sign in a cell reference affects only one thing: it tell Excel how to treat your reference when 
you copy the cell. If a dollar sign precedes a Row number ($10) or Column letter ($E), the row or column don’t 
change when you copy it, otherwise, it will change.  
 
 
 
 
 
  USING THE IF STATEMENT IN COMPUTING STUDENTS GPA AND CGPA 
The IF statement Returns one value if a condition you specify evaluates to TRUE and another value if it 
evaluates to FALSE. 
 Description 
The IF function returns one value if a condition you specify evaluates to TRUE, and another value if that 
condition evaluates to FALSE. For example, in the formula:  =IF(E23>=75,"A1",IF(E23>=70,"A2",IF(E23>=65,"B1",IF(E23>=60,"B2",IF(E23>=55,"C1",IF(E23>=50,"C2",IF(E23>=45,"D1",IF(E23>=40,"D2",IF(E23>=0,"F"))))))))) 

Uses Nested IF conditions to assign a letter grade to the score in cell E23. If cell E23 is greater than or equal 
to 75, give the proceeding scores A1 to F. 

In this example, the IF function is used to test the following seven courses, conditions to test and you may 
find this easier to read and maintain. In the preceding example, the IF statement is evaluated, and the letter 
grades are assigned to numbers using the approved grading system.  GRADE POINT AVERAGE (GPA) 
The Grade Point Average (GPA) of a student in any examination is obtained by dividing the sum of his/her 
Weighted Grade Point (WGP) by total units of the course taken.  

Consider the spreadsheet which shows a student first semester result performance of two ND 1 students 
from the School of Management Sciences in the Department of Mass Communication in Bayelsa State College 
of Arts and Science, Elebele, that has taken eight (8) courses. 

From my design above,  arrows are used to identify the reference point of how the total score, letter grade, 
grade point, total credit units, total grade points, grade point average are calculated and how the letter grades for 
each course are generated accordingly. Total Score: 
The total score of each scores if gotten from performance of class test, assignment and examination written by 
the student for the semester. 
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 Letter Grade: 
From the table above, the letter grade of each course is generated from the total score scored by a student, that is, 
if cell E21 is greater than or equal to 75, it gives the proceeding scores of A1 to F accordingly.  Generating the Letter Grade:  =IF(E11>=75,"A1",IF(E11>=70,"A2",IF(E11>=65,"B1",IF(E11>=60,"B2",IF(E11>=55,"C1",IF(E11>=50,"C2",IF(E11>=45,"D1", IF(E11>=40,"D2",IF(E11>=0,"F"))))))))) 
 
At this point when the formula is entered into a cell used the auto fill handle to fill across rows or used the copy 
and paste command to copy to desire location.  Calculating the Grade Point (GP) 
From the table above, the grade point of each course is a fraction of the course unit multiply by the weighted 
grade point (WGP) accordingly, i.e  
 =IF(E21>=75,4*E$10,IF(E21>=70,3.5* E$10,IF(E21>=65,3.25* E$10, IF(E21>=60,3* E$10,IF(E21>=55,2.75* E$10,IF(E21>=50,2.5* E$10, IF(E21>=45,2.25* E$10,IF(E21>=40,2* E$10,IF(E21>=0,0* E$10))))))))) 
 
At this point when the formula is entered into a cell used the auto fill handle to fill across rows or used the copy 
and paste command to copy to desire location. 
 Total CU: (Summation of the unit of each course (2+2+2+2+3+3+4+2)  Using Microsoft Excel:    
=SUM(E10:L10) = 20   
 Total GP: (Summation of GP (7+7+6.5+5.5+6+6.75+10+0) =SUM(E13:L13) =48.75  Grade Point Average (GPA  
Therefore, GPA= Sum of weighted grade points     
          Total units of courses taken 
   Using Microsoft Excel:     =Cellt11/Cells11 i.e.: (7+7+6.5+5.5+6+6.75+10+0)            = 48.75       =   2.44 
                        (2+2+2+2+3+3+4+2)     20   
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THE CUMULATIVE GRADE POINT AVERAGE (CGPA) 
The Cumulative Grade Point Average (CGPA) is the weighted average of GPA of all the semesters. From the 
table below, the result brought forward (B/F) is the total credit unit, total grade point and grade point average of 
the first semester which will be used to calculate the second semester results of each student 
 
Example: 
In this case, Total CU for 2 semester (1st & 2nd semester) = 46.00   Total GP: (Summation of GP (6.25+10.5+8.25+6.75+7.5+5.5+6+5.5+4.5) =SUM(I16:P16) =62.75 

 Grade Point Average (GPA Therefore, GPA= Sum of weighted grade points      Total units of courses taken Using Microsoft Excel:     = cellAC14/cellAB14 i.e.:     62.75            = 2.61             24  
Therefore, the CGPA =   Cumulated weighted Grade Points         
                    Total Credit Units (for both semesters) 
 
i.e     (56+62.75)             CGPA  =     118.8 =    2.58 
    22+24                                         46  Using Ms Excel =cellAE14/cellAB14 
 Converting from Ms Excel spreadsheet to PDF 
The spreadsheet data can be stored using portable document format (PDF) for safekeeping of such document by 
ensuring that changes will not be allowed on data. To Save to PDF 
• Click on File 
• Click on Save As 
• Click on Browse (search folder to keep files) 
• Type the file name 
• Select PDF under Safe as type 
• Click on Save 
However, you can use print dialog box to print the file to PDF thereby changing the file to PDF filing method.  COPYING GRADING SYSTEM INTO CD 
After final preparation of the grading system(the softcopy), the data can be stored on further retrieval medium 
for future use especially ensuring that such files will be used for further transcript creation to enable faster 
retrieval of student transcript creation.  
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• Insert blank CD/DVD in system compact disk drive 
• Format the CD/DVD as Flash Disk 
• Locate the file folder in the system  
• Right-click on the specific file and Click Copy 
• Then locate and open the CD drive 
• Right-click on CD and then Click Paste 
• Right-click on the CD and click on Eject to remove the CDROM form the drive.  RECOMMENDATIONS 
1. The paper recommends that for effective utilization of this project, all Deans of Schools, Head of 

Departments, examination officers in all departments and the Exams and Records unit be trained for a 
period of one week or more for proper understanding. 

2. I recommend that at the point of result presentation by HOD’s to ACB, a  projector should be used 
during presentation so as to effect any change immediately at the point of result presentation, not to 
give room to individuals to manipulate students result after approval by Academic Board (ACB).  

3. It also recommends that all other secretaries within the departments should be educated on how to assist 
their superiors on preparations of examination results. 

4. Such facilities should be documented and preserved to enable graduating students receive their 
transcript since existing documentation is easy to retrieve. 

5. With this project, there will be improvement on the formats for all departmental results in the College 
i.e making all departmental result to follow a specific format, if possible to add a security feature to the 
printed result. 

6. I also recommend that all departments should have a Google account (Gmail.com) which give all user 
free 15GB of storage space. This space can be used to store all department results online so as to keep 
all results away from theft. 

 CONCUSION 
This project is very important to all students grading systems especially in institutions awarding National 
Diploma and Higher National Diploma considering semester to semester computations. 

However, lecturers/examination officers of various departments are enjoined to study and prepare such 
grading document for present and future presentation of result to Academic Board for approval. It will reduce the 
challenge of computing results into the manual method because the method save time and less cumbersome. 

I therefore enjoin everyone to get acquainted with the software (Microsoft Excel) and embrace the new 
change. 
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